Коммутатор hp как зайти в меню
Перейти к содержимому

Коммутатор hp как зайти в меню

  • автор:

 

[HowTo] Начальная настройка коммутатора HP 1910 серии

howto

По собственному желанию напишу о том, как выполнить начальную настройку коммутаторов HP 1910 серии и братьев-близнецов от 3Com – Baseline Switch 2952 и подобной серии. Вся настройка будет производиться через CLI (Command Line Interface), так как пользоваться web-интерфейсом подчас просто неудобно!

Как осуществить подключение к данному коммутатору, синтаксис команд для входа в режим конфигурирования, я написал в предыдущей статье.

Итак, подключаемся к устройству и входим в режим System View . Просмотрим, что уже сконфигурировано, задаем имя нашему коммутатору ( Main-Switch ), устанавливаем часовую зону (Москва), устанавливаем время и текущую дату, любуемся результатами:

Теперь активируем необходимые сервисы (Telnet и SSH), задаем супер-пароль и пароль локальному пользователю admin (пароли задавайте свои). По желанию, вы можете завести своего пользователя (не забудьте только дать ему разрешение на интересующие вас сервисы: ssh , telnet или terminal ):

Настроим параметры интерфейса Vlan-interface1 (в который объединены по-умолчанию все сетевые интерфейсы коммутатора): его описание, ip-адрес, установим маршрут по-умолчанию ( 192.168.0.1 – маршрутизатор), настроим сервис сетевого времени ntp (на 192.168.0.1 работает ntpd сети):

Зададим настройки для DNS:

Пусть, к примеру, с 1 по 6 интерфейс нашего коммутатора будут не использованными. Зададим каждому из них описание и “опустим” его:

Если вы желаете собирать статистику с помощью snmp , вам необходимо сделать следующие настройки:

Про настройку vlan . Допустим в нашей сети существует vlan 100 , предназначенный для гостей и сторонних пользователей. Разберем общий случай, когда наш настраиваемый сейчас коммутатор является “проходным”. Т.е. к нему непосредственно подключено два “гостя” из подсети, настроенной для vlan 100 (порты GigabitEthernet 1/0/20 и GigabitEthernet 1/0/21 , в которых будет непосредственно тегированный трафик) и два порта являются транслирующими гибридными ( GigabitEthernet 1/0/27 и GigabitEthernet 1/0/28 , по которым идет и тегированный трафик, и нетегированный).

Обозначим наличие нашего vlan и сделаем описание для портов GigabitEthernet 1/0/20 и GigabitEthernet 1/0/21 :

Настроим гибридные порты GigabitEthernet 1/0/27 и GigabitEthernet 1/0/28 :

Теперь можно просмотреть, что у нас получилось и сохраним сделанные изменения:

Как настроен тот или иной элемент вашей конфигурации можно просмотреть с помощью команды display + …

Отменить какую-либо настройку можно с помощью команды undo .

Вот, в принципе, и все. Именно с такими настройками у меня работает несколько коммутаторов в сети с поддержкой нескольких vlan .

PS: Среди коммутаторов HP эту статью можно применить к моделям JE005A, JE006A, JE007A, JE008A, JE009A, JG348A, JG349A, JG350A

Если у тебя есть вопросы, комментарии и/или замечания – заходи в чат, а так же подписывайся на канал.

Настройка коммутатора HP 1910 серии

Здравия всем! Попал мне в руки L3 коммутатор HP V1910-24G Switch JE006A. Крутил вертел его, что-то он мне напоминает. И точно это же старый добрый 3Com Baseline Switch 2900 серии. Мне нужно было его настроить. Тут оставлю запись для себя, чтобы потом снова не искать в сети.

Памятка

Консоль

Порт консоли находится спереди, подходит стандартный Cisco консольный кабель. Настройки консоли

  • Speed — 38400
  • Data bits — 8
  • Stop bits — 1
  • Flow — None

Логин и пароль по-умолчанию, используемые в коммутаторах данных серий: Admin с пустым паролем

Вход в режим конфигурирования

Вход в режим конфигурирования _cmdline-mode on потребуется заводской пароль 512900

После этого входим в режим System View, с помощью команды system-view

Вместо cisco команды show, используем display

Сброс настроек

При загрузке коммутатора на экране появится надпись Press Ctrl-B to enter Extended Boot menu, нужно успеть нажать Ctrl+B. BootRom password, по умолчанию пустой.

После этого появится BOOT MENU. Нам нужен 7 пункт: 7. Skip current system configuration (Пропустить существующую системную настройку), подтверждаем вопрос Y, после этого снова появится меню, выберем пукт 0. Reboot и перегружаем коммутатор

После перезагрузки появится приглашение ввести ENTER. Попадем сразу в командную строку. Чтобы попасть в режим конфигурирования нужно набрать _cmdline-mode on потребуется заводской пароль 512900

Теперь собственно вводим initialize произведем общий сброс устройства к заводским настройкам, после чего коммутатор автоматически перезагрузится:

Начальная настройка

После перезагрузки коммутатор скажет, что конфигурации нет Retrieving configuration file failed! Входим, нажимая ENTER, логин/пароль: admin/пустой пароль

Снова входим в режим конфигурирования, а затем в System View, где доступны все существующие команды CLI с помощью system-view:

Меняем имя коммутатора

Устанавливаем часовую зону, у меня Московскую, и устанавливаем время:

Теперь активируем удаленный доступ по Telnet и SSH

Зададим супер-пароль и пароль локальному пользователю admin

Настроим параметры интерфейса Vlan-interface1, который настроен по умолчанию на все порты. Добавим описание, ip адрес, основной шлюз, DNS:

Включим SNMP для сбора статистики:

Добавим vlan 10, сделаем первый порт транковым, он здесь называется гибридный, и добавим его на первый порт, а также пропишем его на 10 порт в аксесе.

Сохраняем конфигурацию, иначе после перезагрузки все настройки пропадут:

Прошивки

Прошивки для данной модели можно найти по адресу: link

Добавить комментарий Отменить ответ

Этот сайт использует Akismet для борьбы со спамом. Узнайте, как обрабатываются ваши данные комментариев.

Настройка коммутаторов HP через командную строку (CLI)

Общеизвестно и всячески подчеркивается HP, что многие коммутаторы HP (HPE) настраиваются через web-интерфейс. Немного менее известно, что полноценная настройка большого количества коммутаторов также возможно через командную строку (например 1910, 1920).

Подключение к коммутатору возможно либо через сеть (если знаете его IP) либо при наличии физического доступа — через консольный кабель (идет в комплекте), подходит также консольный кабель от Cisco (проверено на HPE 1920). В случае подключения через консольный кабель, в программе доступа (Putty, minicom) необходимо установить следующие параметры:

  • Speed (baud) – 38400
  • Data bits – 8
  • Stop bits – 1
  • Flow control – None

В случае, если консоль коммутатора видна, но на клавиатуру он не реагирует, скорее всего Вы забыли правильно установить Flow control

Для свежераспакованного комутатора логин: admin, без пароля.
По-умолчанию в режиме командной строки Вам доступно только несколько команд. Но если ввести скрытую команду
_cmdline-mode on
то появляется запрос на подтверждение этой команды:
All commands can be displayed and executed. Continue? [Y/N] — нужно нажать y
с последующим запросом на ввод заводского пароля. Возможны следующие варианты:

Коммутатор hp как зайти в меню

hp-serial-cable

profilic-usb-2-serial-com-portProlific USB to Serial Com Port.

 

com-port-windows

Speed (baud) – 38400;
Data bits – 8;
Stop bits – 1;
Flow control – None

7. Skip current system configuration

  • sw> — это режим оператора,
  • sw# — это режим менеджера,
  • sw(config)# — это конфигурационный режим.
  • in-band — когда управляющий трафик повторяет путь обычных данных (то есть, управляющий трафик идет через те же порты, что и данные),
  • out-band — когда управляющий трафик использует выделенный путь.
  • Telnet
  • SSH
  • SNMP
  • HTTP
  • HTTPS
  • Консоль
  • CLI (интерфейс командной строки или командная строка) — к ней можно получить доступ с помощью консоли, Telnet или SSH;
  • Меню — псевдографические меню, в которые можно попасть из командной строки:
    • Setup — простое меню с ограниченными возможностями, тут можно выполнить только самые базовые настройки,
    • Menu — более мощное меню, с широкими возможностями по настройке, просмотру настроек и поведения коммутатора. Возможностей тут меньше, чем в командной строке, но всё же достаточно много. Один из вариантов, когда это меню особо удобно использовать — когда необходимо просмотреть динамическую статистику интерфейсов. Если выполнить команду show из командной строки, то вывод будет показывать срез информации, а в Menu есть возможность просматривать эту статистику в динамике (то есть она будет изменяться в реальном времени);
    • к CLI — Telnet,
    • к веб-интерфейсу — HTTP.
    • manager — указывает, что будут задаваться параметры для уровня доступа менеджер,
    • operator — указывает, что будут задаваться параметры для уровня доступа оператор,
    • all — указывает, что будут задаваться параметры для режимов менеджер и оператор,
    • port-access — задание пароля оператора для аутентификации по 802.1X,
    • user-name — задание имени пользователя для соответствующего режима доступа,
    • hash-type — указывает какой алгоритм используется для хеширования пароля:
      • plaintext
      • sha1
      [править] Настройка Telnet
      [править] Настройка SSH, SSL и авторизованных менеджеров
      • к CLI — Telnet,
      • к веб-интерфейсу — HTTP.
      • к CLI — SSH,
      • к веб-интерфейсу — HTTPS (SSL).
      • доступа к коммутатору с помощью Telnet;
      • доступа к коммутатору с помощью SSH, HTTP, HTTPS;
      • SNMP;
      • передачи файлов (конфигурационных и ОС) по TFTP.
      [править] Management Interface Wizard
      [править] SSH-клиент и telnet-клиент
      • primary
      • secondary
      • включает tftp-сервер на коммутаторе
      • копирует информацию в файл, в формате <год>-<месяц>-<день>-<имяустройства>.txt
      • отключает tftp-сервер на коммутаторе
      • Unicast — в этом режиме необходимо указать адрес SNTP-сервера. Если указаны несколько серверов (максимум можно указать 3 сервера), то коммутатор выбирает к какому обращаться:
        • В 3400, 5300 моделях: по IP-адресу — сначала он запрашивает сервер с наименьшим адресом, если тот не отвечает, то у следующего,
        • В 3500, 5400 моделях: по указанному приоритету — можно указать приоритет со значением от 1 до 3, сервера будут запрашиваться по порядку в соответствии с приоритетом,

        [править] Logging

        [править] LLDP и CDP

        [править] Агрегирование каналов (Port aggregation)

        • 3400, 5300 — поддерживают RSTP и MSTP,
        • 3500, 5400 — поддерживают MSTP.
        [править] Маршрутизация на основе политик (policy-based routing, PBR)
        • настройка значения next-hop (<ipv4 | ipv6> ip next-hop <ipaddr>)
        • настройка значения next-hop для пакетов, для которых нет специфического маршрута (<ipv4 | ipv6> ip default-next-hop <ipaddr>)
        • настройка исходящего туннельного интерфейса (interface tunnel <tunnel-ID>)
        • настройка интерфейса null, который указывает, что пакеты будут отброшены, если к ним не применяются другие действия ранее
        • Для класса могут быть настроены несколько действий, до 8 действий для одного класса
        • Если настроено действие интерфейс null, то другие действия для этого класса не могут быть настроены
        • Только одно из 8ми возможных действий может быть активно в один момент времени
        • Приоритет действий определяется порядком в котором они добавлены в политику
        • Действия могут быть добавлены только к классу. Они добавляются в конец списка действий для класса
        • Для того чтобы удалить действия примененные к классу, весь класс должен быть удален из политики
        • Когда действие становится недоступным (неактивным), например, если настроенный адрес становится недостижимым (для действий next-hop и default-next-hop) или интерфейс находится в состоянии down (для tunnel), политика просматривает следующие действия. Список действий просматривается до тех пор пока не дойдет до правила interface null или конца списка действий. Если достигнут конец списка, то политика не применяется и соответствующий класс обрабатывается без учета PBR.
        • Максимальное количество уникальных IP-адресов next-hop и default-next-hop — 256

        [править] Настройка Multicast

        [править] UDP Broadcast Forwarding

        • dns: Domain Name Service (53)
        • ntp: Network Time Protocol (123)
        • netbios-ns: NetBIOS Name Service (137)
        • netbios-dgm: NetBIOS Datagram Service (138)
        • radius: Remote Authentication Dial-In User Service (1812)
        • radius-old: Remote Authentication Dial-In User Service (1645)
        • rip: Routing Information Protocol (520)
        • snmp: Simple Network Management Protocol (161)
        • snmp-trap: Simple Network Management Protocol (162)
        • tftp: Trivial File Transfer Protocol (69)
        • timep: Time Protocol (37)

        sun#conf t
        sun(config)#int ethernet 9-10
        sun(eth-9-10)#disable

        sun#sh run
        interface 9
        disable
        exit
        interface 10
        disable
        exit

        sun# sh interfaces brief
        | Intrusion MDI Flow Bcast
        Port Type | Alert Enabled Status Mode Mode Ctrl Limit
        ——- ——— + ——— ——- —— ———- —— —— ——
        .
        9 100/1000T | No NO UP 1000FDx MDIX off 0
        10 100/1000T | No NO UP 1000FDx MDIX off 0
        .

        sun#conf t
        sun(config)#trunk 9-10 trk1 trunk

        sun#conf t
        sun(config)#trunk 9-10 trk1 LACP

        trunk 9-10 Trk1 Trunk

        sun#conf t
        sun(config)#vlan 105 untagged trk1

        vlan 105
        name «VLAN105»
        untagged 1,Trk1
        ip address xx.xx.xx.xx 255.255.255.0
        exit

        Настройка времени на Procurve 3500yl

        sun(config)#sntp server priority 1 62.149.0.30

        sun(config)#clock timezone gmt +2:00

        sun(config)#clock
        16:31:14 GMT +02:00 Wed Apr 6 2011

        sun(config)#sh time
        Wed Apr 6 16:31:37 2011

        02631 SNTP: server not found at 10.1.1.1

        connection-rate

        switch(config)# connection-rate-filter sensitivity <low | medium | high | aggressive>

        Уровень чувствительности обнаружения Частота запросов на соединение (сек) Количество новых адресов получателей Период блокирования (сек)
        Low < 0.1 54 <30
        Medium < 1.0 37 30-60
        High < 1.0 22 60-90
        Aggressive < 1.0 15 90-120

        sun(config)# connection-rate-filter sensitivity medium

        sun(config)#filter connection-rate 1-3 notify-only
        sun(config)#filter connection-rate 7-9 block
        sun(config)#filter connection-rate 15-16 throttle

        sun(config)# show connection-rate-filter
        Connection Rate Filter Configuration
        Global Status: Enabled
        Sensitivity: Low
        Port | Filter Mode
        ————+——————
        1 | NOTIFY-ONLY
        2 | NOTIFY-ONLY
        3 | NOTIFY-ONLY
        7 | BLOCK
        8 | BLOCK
        9 | BLOCK
        15 | THROTTLE
        16 | THROTTLE

        sun(config)# show connection-rate-filter all
        VLAN ID | Source IP Address | Filter Mode
        ————-+——————-+————
        10 | 13.28.234.175 | THROTTLE
        10 | 13.28.234.179 | THROTTLE
        15 | 13.28.234.180 | BLOCK

        Src IP xxx.xxx.xxx.xxx blocked

        Src IP 10.1.0.18 high connection rate, port 3

        sun(config)# connection-rate-filter unblock
        all Resets all previously blocked by the connection rate filter
        host Match packets from the specified IP address.
        IP-ADDR/MASK-LENGTH Match packets from the specified subnet.

        ip access-list connection-rate-filter < crf-list-name >
        < filter | ignore > ip < any | host < ip-addr > | ip-addr < mask >>
        < filter | ignore > < udp | tcp > < source > < options >
        vlan < vid > ip access-group < crf-list-name > connection-rate-filter

        sun(config)#ip access-list connection-rate-filter 17-server
        sun(config-crf-nacl)#ignore ip host 15.45.50.17
        sun(config-crf-nacl)#exit
        sun(config)#vlan 15
        sun(vlan-15)#ip access-group 17-server connection-rate-filter

        sun# sh vlans
        Status and Counters — VLAN Information
        .
        Maximum VLANs to support : 256
        .

        sun(config)# max-vlans 2048

        Command will take effect after saving configuration and reboot.

        sun# wr mem
        sun# reload

        sun(config)# sh vlans
        Status and Counters — VLAN Information
        .
        Management VLAN :
        .

        sun(config)# management-vlan 100
        sun(config)# sh vlans
        Status and Counters — VLAN Information
        .
        Management VLAN : VLAN100

        sun(config)#no management-vlan 100

        sun(config)# sh vlans
        Status and Counters — VLAN Information
        Primary VLAN : DEFAULT_VLAN
        VLAN ID Name | Status Voice Jumbo
        ——- ——————— + ———- —— ——
        1 DEFAULT_VLAN | Port-based No No

        sun(config)# primary-vlan 101

        sun(config)# sh vlans
        Status and Counters — VLAN Information
        Primary VLAN : VLAN100
        VLAN ID Name | Status Voice Jumbo
        ——- ——————— + ———- —— ——
        1 DEFAULT_VLAN | Port-based No No

        sun(config)# vlan 100 voice

        sun(config)#vlan 100 qos priority 7

        Trunk и agregate связка между HP Procurve 3500yl и Linksys

        hp#conf t
        hp(config)#trunk 23-24 Trk1 Trunk

        Linksys:

        linksys# configure
        linksys(config)# interface ethernet g1
        linksys(config-if)# channel-group 1 mode auto
        linksys(config)# interface ethernet g2
        linksys(config-if)# channel-group 1 mode auto
        linksys(config-if)# exit

        hp#conf t
        hp(config)#vlan 101
        hp(config)#vlan 102

        hp#conf t
        hp(config)#vlan 101
        hp(vlan-101)# tagged trk1
        hp(vlan-101)# vlan 102
        hp(vlan-102)# tagged trk1

        Linksys:

        linksys#conf
        linksys(config)#vlan database
        linksys(config-vlan)#
        linksys(config-vlan)#vlan 101
        linksys(config-vlan)#vlan 102

        linksys#conf
        linksys(config)#interface port-channel 1
        linksys(config-if)#switchport mode trunk
        linksys(config-if)#switchport trunk allowed vlan add 101
        linksys(config-if)#switchport trunk allowed vlan add 102

         

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *